npm es el administrador de paquetes oficial de Node.js, el marco de E / S asíncrono sin bloqueo que utiliza el motor JavaScript V8 de Google. Se puede utilizar para instalar y publicar módulos CommonJS, complementos jQuery, código JavaScript reutilizable (bibliotecas) y programas CLI basados en JavaScript.

npm...

Estoy usando el paquete Open para iniciar URL en varios navegadores. No parece haber una gran documentación sobre cómo iniciar con navegadores específicos en cada sistema operativo. Descubrí que puedes hacer esto para Mac const open = require('open'); await open('https://www.github.com', { app: 'mi....
8 ago. 2020 a las 00:06
Quiero mostrar una rueda de lotería en mi proyecto de afición. Encontré este paquete en npm 'lottery-wheel' e intenté instalarlo y renderizarlo sin éxito. Lo instalé con: npm install lottery-wheel Lo incluí en el archivo de componentes: import Wheel from 'lottery-wheel'; Quiero renderizarlo dentro....
7 ago. 2020 a las 20:55
Estaba tratando de hacer una aplicación con vue e instalé el comando npm. Cuando ejecuto el comando "npm run serve", obtengo los siguientes mensajes. Parece que se suponía que debía ejecutar la aplicación en "http: // localhost: 8080 /" y pude acceder a las páginas de muestra, no como "x86_64-apple-....
4 ago. 2020 a las 11:20
Instalo npm para crear mi proyecto react-native usando el siguiente comando npm install -g expo-cli Pero desafortunadamente no puedo instalarlo. da error de seguimiento. npm ERR! code EPERM npm ERR! syscall unlink npm ERR! path C:\Users\kkawm\AppData\Roaming\npm\node_modules\.staging\@expo\xdl-f25....
3 ago. 2020 a las 09:19
He estado trabajando en muchos proyectos de node.js diferentes. Todos ellos tienen su propio archivo package.json con sus propios paquetes necesarios. Cada vez que ejecuto node <mainfile>.js, npm instala todos los paquetes en el directorio del proyecto. Así: C:/Users/me/Projects/<project-name>/nod....
3 ago. 2020 a las 05:42
Estoy aprendiendo Node.js y en el curso introductorio, tuve que configurar node y npm. Ahora, según el instructor, después de escribir "npm start" en la terminal y luego realizar cambios en el archivo index.html, se supone que el navegador actualiza automáticamente la pestaña para que los cambios su....
2 ago. 2020 a las 10:54
Hola, soy realmente nuevo en reaccionar y no puedo entender cómo instalarlo o lo que sea que tenga que hacer para escribir código en él. Descargué node.js y tengo instalada la v12.18.3 y también NPM 6.14.6, pero cada vez que intento escribir los comandos en el método de instalación create-react-app ....
31 jul. 2020 a las 20:25
Agregué este script npm a mi archivo package.json: "gitlog" : "git log --graph --decorate -30 --all --date-order --date=format:'%Y-%m-%d %H:%M:%S' --pretty=format:'%C(cyan)%h%Creset %C(black bold)%ad%Creset%C(auto)%d %s'" Pero cuando escribo npm run gitlog, aparece el error: fatal: Invalid object n....
29 jul. 2020 a las 17:54
En un archivo .babelrc , escribí: "plugins": [ [ "@babel/plugin-proposal-class-properties" ] ] En mi clase, escribí: class Login extends React.Component { constructor(props){ super(props); this.state={ ... }; this.changeValue=this.cha....
29 jul. 2020 a las 08:50
Estoy tratando de crear un control deslizante en mi aplicación reaccionar nativa de Android, y es relativamente nuevo en React Native. La documentación de React Native dice que su componente Slider está obsoleto (https://reactnative.dev/docs/slider.html) y nos indica que usemos @ react-native-commun....
28 jul. 2020 a las 10:14
No puedo instalar Gatsby plugin for Netlify CMS en mi blog. He estado siguiendo un tutorial de agregando Netlify CMS al blog existente y también se refirió a esto doc. Pasos para reproducir Aquí hay un enlace a mi repositorio: https://github.com/mohammedasker/blogger Clona mi repositorio y dirígete ....
26 jul. 2020 a las 15:52
Estoy intentando crear una aplicación modular en Vue a través de vue-cli-service. La aplicación principal y los módulos son proyectos separados que viven en carpetas diferentes, la estructura es algo como esto: -- app/package.json /src/** -- module1/package.json /src** -- module2/pac....
25 jul. 2020 a las 12:25
Estoy tratando de instalar npm y sigo recibiendo errores. Inicialmente, el problema era que necesitaba un archivo package-lock.json y un archivo package.json y eso se resolvió escribiendo "npm init" en el terminal. Luego, cuando intentaba ejecutar "npm start", decía que me faltaba el script de inici....
24 jul. 2020 a las 19:30
Tengo una carpeta de métodos util, 50+, y se dividen en dos carpetas, db y utils. Todos los métodos están en diferentes archivos dentro de esas dos carpetas Sin embargo, cuando llamo al paquete Quiero poder poder hacer simplemente: let { db, utils } = require ('utils') db.insertRecord("Lucas") util....
24 jul. 2020 a las 03:33
Siguiendo un cierto tutorial, bajé mi npm de 6.14.1 a versión 5.5.1 . Pero cada vez que instalo un paquete usando npm, ya no funciona y ya tiene problemas de compatibilidad. Dice: npm WARN npm You should probably upgrade to a newer version of node as we npm WARN npm can't make any promises that n....
23 jul. 2020 a las 12:16
Soy principiante en node.js. Estoy tratando de llamar a un módulo de adición muy básico guardado en C: \ wks \ guru99 con el nombre del archivo: Node_03_addition.js. La aplicación de llamada también se guarda en la misma ubicación con el nombre: app.js Módulo de adición: var exports = module.exports....
23 jul. 2020 a las 05:53
Estoy aprendiendo el desarrollo web siguiendo un curso y llegó el momento de instalar express usando el administrador de paquetes de nodos. Tuve que instalar express y utilicé el siguiente comando: npm install express Y recibí un error que decía: npm ERR! code EAI_AGAIN npm ERR! errno EAI_AGAIN n....
21 jul. 2020 a las 11:46
Aquí está mi Dockerfile que está en la raíz de la aplicación nodejs. # Build from LTS version of node (version 12) FROM node:12 # Create app directory RUN mkdir -p /usr/src/app # Define app diretory inside image WORKDIR /usr/src/app # package.json AND package-lock.json are copied where available....
19 jul. 2020 a las 11:16
Estaba trabajando en un proyecto Quasar en mi máquina con Windows y de repente dice quasar is not recognized as an internal or external command. Intenté desinstalar quasar-cli con el comando npm uninstall -g quasar-cli pero parece que no funciona. El comando npm list -g --depth=0 me dice que todavía....
19 jul. 2020 a las 07:29
Estoy buscando una manera de automatizar un tedioso trabajo que desafía a los humanos al vincular múltiples objetos JSON en GUID aleatorios. Hay varios archivos con formato JSON interconectados: { "name": "some.interesting.name", "description": "helpful description", "instanceId": "rando....
17 jul. 2020 a las 18:52
Después de compilar la aplicación angular con api node.js, la implementación de heroku da el siguiente error. pero cuando ejecuto mi aplicación en localserver funciona perfectamente sin errores. Esta es mi heroku registros C:\Users\PC>heroku logs -a=ts-ecommerce-project 2020-07-16T10:55:21.649783+....
16 jul. 2020 a las 14:28
Tengo problemas para instalar el nodo js en ejecución en mi ubuntu 18 pc. Ejecuto los siguientes comandos paso a paso: sudo apt update curl -sL https://deb.nodesource.com/setup_14.x | sudo bash - sudo apt -y install nodejs Y luego comprobé el número de versión: node -v v8.10.0 Más tarde eliminé no....
16 jul. 2020 a las 12:06
Parece que este es un problema bastante común, pero he intentado todo lo que pude encontrar y todavía parece que no puedo resolverlo. Si cargo mi terminal fuera de VS Code, funciona bien, pero el terminal integrado sigue lanzando esto cuando comienza: internal/modules/cjs/loader.js:638 throw err....
15 jul. 2020 a las 22:58
Sé que esta pregunta se publica muchas veces, pero probé las soluciones y no puedo resolverla. Estoy tratando de trabajar con npm, sin embargo, aparece este error: evalmachine.<anonymous>:35 } = primordials; ^ ReferenceError: primordials is not defined at evalmachin....
14 jul. 2020 a las 17:56
Estoy tratando de instalar lo siguiente npm install --save express body-parser firebase functions-helper Pero sigo recibiendo estos errores npm ERR! code E404 npm ERR! 404 Not Found - GET https://registry.npmjs.org/functions-helper - Not found npm ERR! 404 npm ERR! 404 'functions-helper@latest' is....
13 jul. 2020 a las 15:21