Recientemente actualicé gulp a la versión 4.0.2 en uno de mis proyectos y me gustaría actualizar las instrucciones de instalación de mi README. Obviamente, uno de los requisitos es npm y node. Me gustaría saber qué versión de npm y node se requiere para que gulp v4.0.2 funcione, se requiere la versión mínima.

Traté de buscar la respuesta en la documentación de Gulp, pero fue en vano. https://www.npmjs.com/package/gulp

0
marcos 31 dic. 2019 a las 21:12

2 respuestas

Mirando el package.json de Gulp hay un engines entrada:

  "engines": {
    "node": ">= 0.10"
  },

Así que supongo que lo mantienen actualizado y la versión mínima sería >= 0.10.

En cuanto a la versión npm, busque Node.js 0.10.0 en esta página y encontrarás 1.2.14.

3
Bauke 31 dic. 2019 a las 18:28

El Inicio rápido en los documentos oficiales implica que al menos funcionará con Nodo v8.11.1 y npm 5.6.0.

Sin embargo, no estoy seguro si esos son los requisitos mínimos.

0
skoller 31 dic. 2019 a las 18:22