Recibo este molesto error cada vez que actualizo una página en mi aplicación rails 5. Necesito underscore.js para gmaps4rails. Este archivo underscore.js está en vendor / javascript / underscore.js, como dice el tutorial (Gmaps4Rails Github repo).

¿Alguien tiene una buena solución para resolverlo o suprimirlo?

2
rtrigo 6 mar. 2017 a las 14:25

2 respuestas

La mejor respuesta

Debe agregar el archivo .map o eliminar la línea en su JS que lo llama.

2
Nicolas Maloeuvre 6 mar. 2017 a las 12:32

Para resolver este problema, lo hago:

1) copie el código de underscore-min.map (el enlace está aquí) en un archivo al que renombré underscore-min.map y lo coloqué en la canalización de activos (assets / javascripts)

2) en el subrayado-min.map, reemplace underscore-min.js por underscore.js

3) en underscore.js, descomenta la última línea (sourceMappingURL=underscore-min.map)

Funciona para mi. Espero que te sea de ayuda también.

3
Boanerges7 22 oct. 2017 a las 09:13