Creé dos hosts virtuales. tester.ly y tucnak.me

/ sites-available / Lab:

<VirtualHost tucnak.me:80>
    ServerAdmin kovalevskiy11@gmail.com
    ServerName tucnak.me
    DocumentRoot /home/tucnak/Web/Lab/
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/tucnak/Web/Lab/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>
            #... here smth skipped.
</VirtualHost>

Y / sites-available / Tester:

<VirtualHost tester.ly:80>
    ServerAdmin kovalevskiy11@gmail.com
    ServerName tester.ly
    DocumentRoot /home/tucnak/Web/Tester/
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/tucnak/Web/Tester/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>
            # skipped too.
</VirtualHost>

Y mi salida apache2:

[Mon Feb 13 20:17:07 2012] [warn] VirtualHost tucnak.me:80 overlaps with VirtualHost tester.ly:80, the first has precedence, perhaps you need a NameVirtualHost directive

Creo que algo incorrecto de la directiva causa este problema. Entonces, necesito ayuda.

0
tucnak 13 feb. 2012 a las 22:19

1 respuesta

La mejor respuesta

Puede tener una directiva NameVirtualHost *:80 o NameVirtualHost * en su configuración.

Esto significa que sus directivas de VirtualHost iniciales deben ser:

<VirtualHost *:80>
(...)
<VirtualHost *:80>
(...)

Y no :

<VirtualHost tester.ly:80>
(...)
<VirtualHost tucnak.me:80>
(...)

El nombre del VirtualHost viene dado por la directiva ServerName dentro del VirtualHost, no por el nombre usado en el <VirtualHost xxx>. Y este xxx debería coincidir con una de las declaraciones NameVirtualHost en la configuración principal.

0
regilero 18 feb. 2012 a las 14:56