Tengo una imagen de carga que quiero mostrar en el medio de la pantalla, pero aparece sobre el resto de cosas. Aquí está el código css que uso

#overlay {
position: fixed;
z-index: 99;
top: 0px;
left: 0px;
background-color: #f8f8f8;
width: 100%;
height: 100%;
filter: Alpha(Opacity=90);
opacity: 0.9;
-moz-opacity: 0.9;
}            
#theprogress {
background-color: #fff;
border:1px solid #ccc;
padding:10px;
width: 300px;
height: 30px;
line-height:30px;
text-align: center;
filter: Alpha(Opacity=100);
opacity: 1;
-moz-opacity: 1;
}
#modalprogress {
position: absolute;
top: 40%;
left: 50%;
margin: -11px 0 0 -150px;
color: #990000;
font-weight:bold;
font-size:14px;
}

Funciona en Visual Studio 2010 pero no cuando lo coloco en el servidor

-1
Rene 7 mar. 2012 a las 14:24
¿Qué quieres decir con que viene sobre el resto de tus cosas?
 – 
ThdK
7 mar. 2012 a las 14:28
Pon el resto abajo y ponlo en la parte superior
 – 
Rene
7 mar. 2012 a las 14:31
Te propongo que publiques tu html también.
 – 
ThdK
7 mar. 2012 a las 14:36

1 respuesta

La mejor respuesta

Espero haberte entendido, y si lo hiciera, daría la siguiente respuesta:

<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
        ....
</head>

Recientemente tuve algunos problemas con CSS en los que todo funcionaba bien en mi máquina, pero cuando lo implementé en el servidor, incluso al ejecutarlo en un navegador de la misma versión, obtuve un HTML diferente.

Así que coloqué esta metaetiqueta en mi sección head del HTML y todo funcionó bien.

También puedes probar:

<meta http-equiv="X-UA-Compatible" content="IE=9" />

O

<meta http-equiv="X-UA-Compatible" content="IE=8" />

Espero eso ayude,

1
ClayKaboom 7 mar. 2012 a las 14:35