Cuando intento importar styles.css desde App.js como este

import React from 'react';
import {render} from 'react-dom';
import * as PropTypes from 'prop-types';
import {AppProvider, Page, Card, Button} from '@shopify/polaris';
import '@shopify/polaris/styles.css'; // << issue

import SettingsForm from './SettingsForm';

class App extends React.Component { 
static contextTypes = {
  easdk: PropTypes.object,
};

render() { 
  return (
    <AppProvider>
      <Page title="Settings">
        <SettingsForm />
      </Page>
    </AppProvider>
  );
}
}

export default App;

Recibo un error: No se pudo compilar

./node_modules/@shopify/polaris/styles.css (./node_modules/css-loader??ref--6-oneOf-3-1!./node_modules/postcss-loader/src??postcss!./node_modules/@shopify/polaris/styles.css)
Unclosed bracket (3864:37)

  3862 |     background-color:#c4cdd5;
  3863 |     background-color:var(--progress-upper, #c4cdd5);
> 3864 |     background-image:linear-gradient(to right, transparent 0%, transparent 0%, transparent 100%, transparent 100% transparent;
       |                                     ^
  3865 |     background-image:linear-gradient(to right, var(--progress-lower, transparent) 0%, var(--progress-lower, transparent) var(--Polaris-RangeSlider-progress, 0%), var(--progress-upper, transparent) var(--Polaris-RangeSlider-progress, 100%), var(--progress-upper, transparent) 100%);
  3866 |     border:none;

Verifiqué que el CSS dentro de node_modules/@shopify/polaris/styles.css es el mismo que https://sdks.shopifycdn.com/polaris/2.12.1/polaris.css

Hice una búsqueda global de esta línea background-image:linear-gradient(to right, transparent 0%, transparent 0%, transparent 100%, transparent 100% transparent; pero el resultado fue 0

¿Por qué aparece un error aquí y cómo puedo solucionarlo, por favor? gracias.

1
t q 16 oct. 2018 a las 17:42

2 respuestas

La mejor respuesta

Este era un problema conocido

https://github.com/Shopify/polaris/issues/441

Actualice a la última / próxima versión (3.0.0-RC3) y debería estar bien.

1
cdavid15 22 oct. 2018 a las 20:07

No importe css en node_modules en App.js, si desea sobrescribir algunas configuraciones en node_modules, debe crear un archivo css o menos, e importar el css en css o menos, y hay muchas propiedades css en @ shopify / polaris / styles.css, no es necesario importarlos todos.

0
Root 16 oct. 2018 a las 15:00