Esta mañana, traté de poner en funcionamiento un estudiante de la cooperativa en una versión anterior de Google App Engine para el complemento Eclipse.

El siguiente sitio web y todos los enlaces relacionados parecen haber sido borrados de la faz de la tierra:

https://developers.google.com/eclipse/

¿Es esto justo abajo en este momento? ¿Es posible obtener versiones anteriores del complemento?

3
Jake88 22 ene. 2018 a las 20:07

3 respuestas

La mejor respuesta

Es probable que esa documentación oficial haya desaparecido definitivamente, el complemento ha quedado en desuso a favor de Google Cloud Tools para Eclipse. De Migrar desde el complemento de Google para Eclipse:

El complemento de Google para Eclipse está en desuso y no será compatible más allá de Eclipse 4.6 (Neon). Se eliminará a principios de 2018.

Este documento describe cómo migrar un proyecto que utiliza el complemento de Google para Eclipse a las herramientas compatibles.

Puede consultar las instantáneas de los documentos en el Wayback Machine, y maybe aún encuentran los repositorios de códigos coincidentes, si no se han eliminado también.

Pero probablemente sea una buena idea cambiar a las herramientas compatibles más temprano que tarde, especialmente porque recién están comenzando.

Relacionado: Migración del proyecto GAE a Java 8: obtenga un error de validación XML después de agregar la propiedad de tiempo de ejecución a appengine-web.xml

3
Dan Cornilescu 22 ene. 2018 a las 17:42

GPE se ha ido. No estaba actualizado y muchas partes ya no funcionaban. Durante el próximo año, se rompería aún más la funcionalidad principal. No le haríamos ningún favor a nadie al dejar que invierta su tiempo en una herramienta rota. Esto es doblemente cierto para los nuevos usuarios, como sus estudiantes. Hay algunas instantáneas antiguas de GPE que flotan por aquí y por allá, pero realmente no funcionan con GCP en 2018.

4
Elliotte Rusty Harold 22 ene. 2018 a las 20:17

Si bien es correcto que el complemento de Google para Eclipse se haya eliminado de la documentación de Google, todavía está disponible.

Para instalarlo, en Eclipse Neon, haga clic en "Instalar nuevo software" y agregue esta URL.

http://dl.google.com/eclipse/plugin/4.6

A continuación, haga clic en los diálogos para permitir la instalación y reinicie Eclipse.

Si bien Google ha optado por dejar de admitir esto, personalmente creo que el nuevo complemento Cloud Tools para Eclipse simplemente no está listo. Además, en los primeros días, JDO era lo que muchas personas usaban en la parte superior de la capa de datos, y dado que GAE ha existido por más de 10 años, muchos de nosotros tenemos una gran infraestructura construida además de esto que es costoso cambiar . Aunque todavía es posible, en teoría, ejecutar el potenciador de DataNucleus manualmente, es un gran dolor que requiere un conocimiento profundo del funcionamiento interno de GAE y DataNucleus y el conocimiento de qué dependencias van juntas. Puede haber estado bien documentado en el pasado, pero hoy no lo está.

Pero tenga en cuenta que uno de nuestros ingenieros recientemente perdió la capacidad de implementar el proyecto en Google App Engine usando el GPE y se vio obligado a usar la herramienta gcloud, que no parece tener valores predeterminados razonables, como la implementación en una versión no predeterminada y en su lugar se desplegará directamente al predeterminado, bueno, por defecto. Entonces, estamos escribiendo un script alrededor de ese comando que pasará en --no-promote para que no comience a migrar el tráfico de inmediato ... Visite referencia de gcloud para el despliegue de la aplicación para más detalles. ¡Buena suerte!

Para obtener más información sobre el proceso de instalación, consulte Cómo instalar Google Plugin para Eclipse en mkyong.com.

4
jmort253 21 jun. 2018 a las 14:10