Estoy tratando de aprender Python siguiendo el libro "Python Crash Course", pero estoy atascado porque el libro no usa el IDE que estoy usando, PyCharm.

El problema que encuentro es cuando trato de importar pygame y dice module not found.

Instalé exitosamente pygame usando este comando:

python -m pip install --user pygame

captura de pantalla del símbolo del sistema

Recibo el mensaje "Pygame instalado correctamente"

Pero aún no puedo importarlo. Noté que PyCharm usa el intérprete desde esta ubicación: \HelloWorld\venv\Scripts\python.exe

Que está dentro de la carpeta del proyecto.

Mi python está instalado en:

\AppData\Local\Programs\Python\Python36-32\python.exe

¿Cómo puedo dar acceso al entorno virtual de PyCharm a pygame?

¡Gracias!

2
Darren 26 feb. 2018 a las 08:24

4 respuestas

La mejor respuesta

Necesita cambiar su intérprete de proyecto de pycharm

Llegó a Archivo -> Configuración -> su_proyecto -> intérprete de proyecto

Y luego seleccione el Venv donde ha instalado la biblioteca requerida.

enter image description here

1
om tripathi 26 feb. 2018 a las 05:32

Gracias por todas sus sugerencias. Tanto la respuesta de jackotonye como la de om tripathi son correctas. Simplemente prefiero las de jackotonye, pero en lugar de 'agregar local', instalo el módulo pygame.

Esto es lo que hice, en PyCharm para ir:

File -> Settings -> Project: HelloWorld -> Project Interpreter -> '+' (plus sign)

Esto le permitirá instalar paquetes / módulos en su venv.

Pero creo que tendrá que hacer esto para cada proyecto que creará a menos que haya seleccionado "Configuración predeterminada" en lugar de "Configuración" en la instrucción anterior que indiqué.

PD: la respuesta de om tripathi también funciona, cambiando el intérprete a mi python nativa en lugar de la python de venv.

¡Gracias!

0
Darren 27 feb. 2018 a las 03:11
PyCharm -> Prefrences -> Project -> Project Interpreter -> Add Local
1
jackotonye 26 feb. 2018 a las 05:33

Intente instalar el paquete desde el intérprete de proyecto proporcionado en pycharm

1
Harsh Mehta 26 feb. 2018 a las 05:33