Estoy tratando de instalar matplotlib-basemap a través del indicador de Anaconda, pero simplemente no funciona.

Cuando escribo:

conda install basemap

El error que da es:

UnsatisfiableError: The following specifications were found to be in conflict:
  - basemap
  - xlsxwriter

¿Esto significa que necesito desinstalar xlsxwriter (aunque lo necesito)? ¿Cómo desinstalo esto entonces?

También intenté descargarlo a través de https://www.lfd.uci.edu/~ gohlke / pythonlibs / # mapa base:

pip install basemap-1.1.0-cp27-cp27m-win_amd64.whl

Pero entonces el error es:

basemap-1.1.0-cp27-cp27m-win_amd64.whl is not a supported wheel on this platform.
3
Jellyse 4 mar. 2018 a las 14:29

4 respuestas

La mejor respuesta

Funcionó cuando escribí:

conda install -c conda-forge basemap
7
Jellyse 4 mar. 2018 a las 12:32

Tuve que hacer lo mismo varias veces. Ejecutar como administrador >>> "Símbolo de Anaconda" y luego escribir:

conda install -c conda-forge basemap

Funcionó para mí.

0
SHR 2 jul. 2018 a las 08:13

Recibí el mismo mensaje de error. Actualicé conda, y después de eso conda install -c conda-forge basemap funcionó para mí.

0
Atroka 29 sep. 2019 a las 22:15

Funcionará si escribe este comando:

conda install -c conda-forge basemap
1
merin 24 ene. 2020 a las 01:38