Cada vez que quiero ejecutar mi proyecto aparece el siguiente error

Error: Error de ejecución para la tarea ': aplicación: transformClassesWithDexForDebug'. com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.dex.DexException: Varios archivos dex definen Landroid / support / design / widget / CoordinatorLayout $ 1;

apply plugin: 'com.android.application'

android {
    compileSdkVersion 27
    buildToolsVersion "27.0.2"
    defaultConfig {
        applicationId "com.example.invinciblesourav.flacom"
        minSdkVersion 18
        targetSdkVersion 27
        versionCode 1
        versionName "1.0"    
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"

    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/assets/'] } }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
        exclude group: 'com.android.support', module: 'support-annotations'
    })

    compile ('com.android.support:appcompat-v7:27.+')
    compile 'com.android.support.constraint:constraint-layout:1.0.2'
    compile 'com.google.firebase:firebase-auth:11.0.4'
    compile 'de.hdodenhof:circleimageview:2.1.0'
    compile 'com.theartofdev.edmodo:android-image-cropper:2.3.+'
    compile 'com.google.firebase:firebase-core:11.0.4'
    compile 'com.google.firebase:firebase-database:11.0.2'
    compile 'com.google.firebase:firebase-storage:11.0.4'
    compile 'com.android.support:design:25.3.1'
    compile 'com.squareup.picasso:picasso:2.4.0'
    testCompile 'junit:junit:4.12'
}


apply pluenter code heregin: 'com.google.gms.google-services'

Por favor, ayúdenme. Estoy atrapado en este problema durante unos días.

2
Sourav Hazra 1 mar. 2018 a las 09:07

5 respuestas

La mejor respuesta

Tuve exactamente el mismo problema. Resuelvo este problema actualizando todas las bibliotecas de soporte de Google a la última versión (27.1.0 al momento de escribir esta solución). También actualicé compileSdkVersion a la versión 27 y buildToolsVersion a la versión 27.0.3. Espero que esto te resuelva el problema.

5
uuzelac 2 mar. 2018 a las 16:23

Solo tienes que agregar multidex verdadero y agregarle una dependencia. Código de verificación:

defaultConfig {
    ...
    multiDexEnabled true
}

Agregar dependencia:

dependencies {
 compile 'com.android.support:multidex:1.0.1'
}

Y si quieres conocer multidex en detalles, mira el siguiente enlace: https://developer.android.com/studio/build/multidex.html

Feliz codificación ...

3
Pratik Satani 1 mar. 2018 a las 06:12

Mi problema estaba relacionado debido al uso de diferentes versiones de la misma biblioteca. Una de mis subdependencias se refería a una versión diferente de com.android.support:design , así que forcé la versión en build.gradle con

configurations.all {
    resolutionStrategy {
        force 'com.android.support:support-v4:27.1.0'
        force 'com.android.support:design:27.1.0'
    }
}
2
Giacomo De Liberali 9 abr. 2018 a las 17:44

Debe habilitar la propiedad multidex en su archivo build.gradle

android {

    compileSdkVersion ..
    buildToolsVersion '...'

    defaultConfig {
       ...
       targetSdkVersion ..
       multiDexEnabled true  // this line will solve this problem
   }
}
0
EKN 1 mar. 2018 a las 06:11

Prueba esto ...

apply plugin: 'com.android.application'

android {
compileSdkVersion 27
buildToolsVersion "27.0.2"
defaultConfig {
    applicationId "com.example.invinciblesourav.flacom"
    minSdkVersion 18
    targetSdkVersion 27
    versionCode 1
    versionName "1.0"

    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"

}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}
sourceSets { main { assets.srcDirs = ['src/main/assets', 'src/main/assets/'] } }
}

dependencies {
compile fileTree(dir: 'libs', include: ['*.jar'])
androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
    exclude group: 'com.android.support', module: 'support-annotations'
})

compile ('com.android.support:appcompat-v7:27.+')
compile 'com.android.support.constraint:constraint-layout:1.0.2'
compile 'com.google.firebase:firebase-auth:11.0.4'
compile 'de.hdodenhof:circleimageview:2.1.0'
compile 'com.theartofdev.edmodo:android-image-cropper:2.3.+'
compile 'com.google.firebase:firebase-core:11.0.4'
compile 'com.google.firebase:firebase-database:11.0.2'
compile 'com.google.firebase:firebase-storage:11.0.4'
compile 'com.android.support:design:25.3.1'
compile 'com.squareup.picasso:picasso:2.4.0'
testCompile 'junit:junit:4.12'
}


apply plugin: 'com.google.gms.google-services'
0
Mitesh Machhoya 1 mar. 2018 a las 06:11