Intenté actualizar la versión 26 a 28 del SDK, pero Gradle muestra un error. ¿Cómo puedo resolver este error?

Dependencias de la unidad de la unidad de los

implementation 'com.android.support:appcompat-v7:28.0.0'
}

La dependencia anterior muestra un error imagen de error

android {
compileSdkVersion 28
useLibrary 'org.apache.http.legacy'
defaultConfig {

    minSdkVersion 14
    targetSdkVersion 28
    versionCode 10
    versionName '1.5'
}

Generar informe de errores

0
Aswin T P 16 oct. 2019 a las 09:24

1 respuesta

La mejor respuesta

El error mencionó claramente que está utilizando dos versiones de la biblioteca de soporte 28.0.0 y 26.1.0. Haga todos los 28.0.0. Espero que esto resuelva tu problema.

También está utilizando alguna biblioteca que ya está migrada a AndroidX. Para usar esto, también debe migrar su proyecto a androidX. Intentar Refactorización> Migrar a AndroidX

Y presione DoRefactor

0
Md. Asaduzzaman 16 oct. 2019 a las 06:53