Estoy tratando de usar 'react-native-video' en mi aplicación, he usado las siguientes líneas para obtenerlo:

npm install --save react-native-video
react-native link react-native-video (since my react native version is  0.59)

Después de hacerlo y usar el componente "Video" de 'react-native-vide' recibí un error como el siguiente: ingrese la descripción de la imagen aquí ¿Cuál es el problema? ¿Qué puedo hacer? ¿algunas ideas?

0
Dmila Ram 1 oct. 2019 a las 14:04

1 respuesta

La mejor respuesta

No vinculó la biblioteca correctamente. Después de haber instalado la biblioteca a través de npm i --save react-native-video, deberá ejecutar react-native link react-native-video para vincularla. Esto puede funcionar o no; de lo contrario, deberá vincularlo manualmente de acuerdo con las instrucciones de instalación de la biblioteca.

Es posible que esté utilizando CocoaPods, en cuyo caso también deberá ejecutar estos comandos: cd ios && pod install

Si recibe un error, lo más probable es que no esté utilizando CocoaPods y este es el enfoque incorrecto.

Tenga en cuenta que luego deberá reinstalar la aplicación en el teléfono / simulador, ya que ha cambiado las dependencias nativas. También deberá hacer esto si está usando Expo (expulsado) o algo similar. Si está usando Expo con el flujo de trabajo administrado (= no expulsado), no puede usar bibliotecas que dependan de la vinculación nativa.

0
Maximilian Krause 1 oct. 2019 a las 11:43