Laravel lanza una versión de seguridad. Estoy usando Laravel 6.18.12 e intento actualizar a 6.18.29, así que cuando actualicé mi archivo composer.json con "laravel/framework": "^6.18.29" recibo este error:

enter image description here

Al leer sobre esto en stackoverflow, veo que las personas que instalaron la doctrina / inflector en 1.4 solucionaron sus problemas. Así que lo hice: composer install doctrine/inflector:1.4 e intenté actualizar nuevamente el laravel con composer update laravel/framework pero ocurrió un nuevo error:

enter image description here

Les instalé también symfony / polyfill-php7.3 (estoy usando PHP 7.3). Hecho que podría actualizar la versión de Laravel, pero siempre recibo este error 401 una vez que intento obtener mis datos de API:

enter image description here

Esto sucede con todas mis solicitudes de API. Parece algo sobre el middleware auth: api, pero no estoy seguro de por qué. Mi usuario ha iniciado sesión en la web, puedo usar cosas de auth (), pero la API parece que el usuario no está autenticado. Todo funcionaba bien antes de esta actualización.

Ps: No estoy usando pasaporte, pero estoy usando Spark junto con mi proyecto.

0
itepifanio 29 jul. 2020 a las 21:47

1 respuesta

La mejor respuesta

Como pensaba, este parche de Laravel tiene que resolverse también en Spark, así que ahora estoy actualizando a la versión más reciente. Para obtener más información: respuesta de Taylor

0
itepifanio 29 jul. 2020 a las 21:23