He codificado http://www.meghanbustardphotography.com/home/ y he vinculado cada imagen a una página diferente (código html a continuación). Sin embargo, solo funciona el primer enlace de cada fila. ¿Cómo puedo arreglar esto?

<div class="row" class="aligncenter">
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/09/colin-karlee-abbotsford-backyard-wedding/">
        <div id="colinkarlee"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/09/andrew-rebecca-whytecliff-park-engagement/">
        <div id="andrewrebecca"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/05/justin-hilary-south-bonson-wedding-2/">
        <div id="justinhilary"></div>
    </a>
</div>
<div class="row" class="aligncenter">
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/07/greg-amanda-beach-grove-wedding/">
        <div id="gregamanda"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/10/cory-nicole-fort-langley-little-white-house-wedding/">
        <div id="corynicole"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2013/09/mike-renae-whonnock-lake-portraits/">
        <div id="mikerenae"></div>
    </a>
</div>

<div class="row" class="aligncenter">
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/08/david-gastown-portraits/">
        <div id="david"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/09/brent-stephanie/">
        <div id="brentstephanie"></div>
    </a>
    <a target="_blank" href="http://www.meghanbustardphotography.com/blog/2014/08/sean-brittany-langley-golf-centre-wedding/">
        <div id="seanbrittany"></div>
    </a>
</div>
0
Hilary 24 ene. 2015 a las 07:30

4 respuestas

La mejor respuesta

Creo que Wordpress no procesa / muestra su HTML directamente. Prueba estos:

https://wordpress.org/plugins/insert-php/

https://wordpress.org/plugins/allow-php-in-posts-and-pages/

-1
shsu 5 feb. 2015 a las 22:35

Tiene un montón de enlaces <p> en el código fuente de la página de visualización que no tienen etiquetas </p> de cierre asociadas. Intente sacarlos y vea si eso ayuda.

Además, consulte el orden de las etiquetas <a> y <div> en su código real. No coinciden con lo que pegaste en tu pregunta.

0
Kyle Booth 24 ene. 2015 a las 04:36

Pon <div id == ... > EN <a target .. /a>

Lo hice y los enlaces funcionaron después de eso.

Puedo proporcionar fotos si no sabes a qué me refiero.

0
elixenide 24 ene. 2015 a las 04:36

Al echar un vistazo a su página real, solo la primera columna tiene

dentro de

<a href="http://www.meghanbustardphotography.com/blog/2014/09/colin-karlee-abbotsford-backyard-wedding/" target="_blank">
    <div id="colinkarlee"></div>
</a>

Para la segunda y la tercera columna, veo que

(s) están fuera de . Esa es la razón por la que no se puede hacer clic en ellos.

<div id="andrewrebecca"></div>
<a href="http://www.meghanbustardphotography.com/blog/2014/09/andrew-rebecca-whytecliff-park-engagement/" target="_blank"> </a>

<div id="justinhilary"></div>
<a href="http://www.meghanbustardphotography.com/blog/2014/05/justin-hilary-south-bonson-wedding-2/" target="_blank"> </a>
1
Nguyen Vu Hoang 24 ene. 2015 a las 04:38