He estado teniendo este problema durante bastante tiempo, mi com.android.support:design:26.1.0 me falla y no tengo idea de qué cambiar.

Estos son mis archivos para el módulo gradle.

Build.gradle (aplicación)

apply plugin: 'com.android.application'

android {
    compileSdkVersion 26
    buildToolsVersion '26.0.2'

    defaultConfig {
        applicationId "com.xxx.yyy"
        minSdkVersion 16
        targetSdkVersion 26
        versionCode 1
        versionName "1.0"
        testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:26.1.0'
    implementation 'com.android.support.constraint:constraint-layout:1.0.2'
    implementation 'com.android.support:design:26.1.0'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.1'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1'
    compile 'com.android.support:support-v4:26.1.0'
    compile 'com.google.android.gms:play-services-vision:9.4.0'
//    compile 'com.android.support:design:26.1.0'
}

//apply plugin: 'com.google.gms.google-services'

El archivo gradle del proyecto

// Top-level build file where you can add configuration options common to all sub-projects/modules.

buildscript {

    repositories {
        google()
        jcenter({ url "http://jcenter.bintray.com/" })
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:3.0.1'
//        classpath 'com.google.gms:google-services:3.2.0'

        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter({ url "http://jcenter.bintray.com/" })
        maven { url "https://maven.google.com" }
    }
}

task clean(type: Delete) {
    delete rootProject.buildDir
}

Error: no se puede resolver la dependencia de ': app @ releaseUnitTest / compileClasspath': no se pudo resolver com.android.support:design:26.1.0.

Error: no se puede resolver la dependencia de ': app @ release / compileClasspath': no se pudo resolver com.android.support:design:26.1.0.

Error: no se puede resolver la dependencia de ': app @ debugUnitTest / compileClasspath': no se pudo resolver com.android.support:design:26.1.0.

Error: no se puede resolver la dependencia de ': app @ debugAndroidTest / compileClasspath': no se pudo resolver com.android.support:design:26.1.0.

Error: no se puede resolver la dependencia de ': app @ debug / compileClasspath': no se pudo resolver com.android.support:design:26.1.0.

Y solo la función 'Snackbar' no funciona, pero el resto parece estar bien.

Cuando cambio el diseño a la versión 25.1.0, funciona, pero choca con otros 26.1.0, por lo que Android Studio no lo recomienda. Nadie..?

He intentado poner el

compile 'com.android.support:design:26.1.0'

En lugar de implementar, no funciona. Cuando intenté cambiar todo a 25.4.0 o cualquier otra versión 25, muchas otras cosas tampoco se compilan. Desmarqué el trabajo sin conexión, intenté eliminar / agregar el directorio Maven, descomentar algunas dependencias más, cambiar todo para compilar en lugar de implementar, pero solo me da más errores.

Sí, he actualizado todos mis SDK a los más nuevos, pero tengo la sensación de que Gradle simplemente no puede descargar ciertas dependencias de los sitios web, por eso no puedo descargar ninguna de las otras dependencias. (Aunque mi trabajo fuera de línea no está marcado)

Además, lo que sea que no esté comentado en el código anterior, significa que he intentado ingresar esas líneas pero no resolvió el problema o más bien creó más problemas.

1
Jayden Choi 7 mar. 2018 a las 05:19

3 respuestas

La mejor respuesta

El problema que me di cuenta al final fue que cuando estaba configurando el proxy de Android, solo configuré 1 proxy que era para HTTP y no me di cuenta de que el proxy HTTPS no estaba configurado.

Entonces, después de solucionar ese problema configurando el proxy HTTPS, no hubo más problemas.

0
Jayden Choi 2 abr. 2018 a las 07:04

Pruebe esto una vez, en lugar de implementar compilar el código gradle de soporte de diseño

compile 'com.android.support:design:26.1.0'

Y eliminar esto

 implementation 'com.android.support:design:26.1.0'
0
Android Geek 12 mar. 2018 a las 05:20

Esta es la forma en que lo encontré, prueba lo siguiente

Go to File->Settings->Build, Execution, Deployment->Gradle->Uncheck Offline work option.
0
akshay 12 mar. 2018 a las 04:24