Instalé TYPO3 v10.4.9 con el paquete boostrap y creé algunas páginas personalizadas para probar cosas. Me di cuenta de que las "URL parlantes" no funcionan y no tengo ni idea de por qué. Tenga en cuenta que soy un gran principiante en TYPO3, por lo que probablemente me esté perdiendo algo obvio.

Ejemplo: Tenemos una página llamada Fotos. La URL creada por "Segmento de URL" en el módulo Página> "Editar propiedades de la página" es https://example.com/photos < / a> y el ID de la página es 84.

Si hago clic en el icono de vista en el módulo de la página, la URL https://example.com/photos se abre en la interfaz y recibo un mensaje que dice "No encontrado: la URL solicitada no se encontró en este servidor".

Por otro lado, si escribo la URL con ID en el navegador manualmente, así: https: / /example.com/index.php?id=84, funciona perfectamente bien. Este problema está presente en todas las páginas que creo. He creado la configuración del sitio. A continuación se muestra el contenido de config.yaml:

base: 'https://example.com'
baseVariants: {  }
errorHandling: {  }
languages:
    title: 'Example Site'
    enabled: true
    base: /
    typo3Language: default
    locale: en_US.UTF-8
    iso-639-1: en
    websiteTitle: ''
    navigationTitle: English
    hreflang: en-US
    direction: ''
    flag: us
    languageId: '0'
rootPageId: 1
routes: {  }
websiteTitle: ''

.htaccess

AddHandler application/x-httpd-php74 .php

#@__HCP_END__@#
# Anything after the comment above is left alone

Por favor ayuda. ¿Que me estoy perdiendo aqui? Si debo pegar más datos para ayudar a resolver el problema, hágamelo saber. Gracias de antemano.

0
t3hc00n 19 feb. 2021 a las 20:15

2 respuestas

La mejor respuesta

Encontré una solución. He copiado el contenido de

https://github.com/TYPO3/TYPO3.CMS/blob/master/typo3/sysext/install/Resources/Private/FolderStructureTemplateFiles/root-htaccess

A .htaccess y ahora funciona perfectamente.

1
t3hc00n 20 feb. 2021 a las 13:42

Quizás falta el .htaccess en la raíz de su instalación.

1
Stephan Grass 19 feb. 2021 a las 17:49