Usando Ubuntu 20 con ARM v8 Raspberry pi, desarrollo de escritorio flutter Linux y el último SDK de dart & flutter.

No hay errores al crear un proyecto y también en flutter doctor, mientras intentaba ejecutar el proyecto me quedé atascado con este error.

flutter run --verbose log....
[+1229 ms] executing: [/home/rpi4/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[ +237 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[ +2 ms] b9d06ff
[ +4 ms] executing: [/home/rpi4/flutter/] git tag --points-at b9d06ff
[ +491 ms] Exit code 0 from: git tag --points-at b9d06ff
[ +1 ms] 1.26.0-8.0.pre
[ +265 ms] executing: [/home/rpi4/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[ +54 ms] Exit code 0 from: git rev-parse --abbrev-ref --symbolic @{u}
[ +2 ms] origin/dev
[ +4 ms] executing: [/home/rpi4/flutter/] git ls-remote --get-url origin
[ +72 ms] Exit code 0 from: git ls-remote --get-url origin
[ +1 ms] https://github.com/flutter/flutter.git
[ +390 ms] Unable to locate an Android SDK.
[ +62 ms] executing: [/home/rpi4/flutter/] git rev-parse --abbrev-ref HEAD
[ +40 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[ +1 ms] dev
[+1075 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[ +4 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[ +27 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[ +4 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[ ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +869 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[ +12 ms] Artifact Instance of 'WindowsEngineArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'MacOSEngineArtifacts' is not required, skipping update.
[ +24 ms] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[ +1 ms] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[ +816 ms] Skipping pub get: version match.
[ +143 ms] Found plugin menubar at /home/rpi4/Desktop/flutter-desktop-embedding/plugins/menubar/
[ +270 ms] Found plugin menubar at /home/rpi4/Desktop/flutter-desktop-embedding/plugins/menubar/
[ +737 ms] Initializing file store
[ +63 ms] Skipping target: gen_localizations
[ +27 ms] complete
[ +34 ms] Launching lib/main.dart on Linux in debug mode...
[ +27 ms] /home/rpi4/flutter/bin/cache/dart-sdk/bin/dart --disable-dart-dev
/home/rpi4/flutter/bin/cache/artifacts/engine/linux-x64/frontend_server.dart.snapshot --sdk-root
/home/rpi4/flutter/bin/cache/artifacts/engine/common/flutter_patched_sdk/ --incremental --target=flutter --debugger-module-names
--experimental-emit-debug-metadata --output-dill /tmp/flutter_tools.NEIKYA/flutter_tool.XNVUMM/app.dill --packages
/home/rpi4/Desktop/flutter-desktop-embedding/plugins/menubar/.dart_tool/package_config.json -Ddart.vm.profile=false -Ddart.vm.product=false --enable-asserts
--track-widget-creation --filesystem-scheme org-dartlang-root --initialize-from-dill build/cache.dill.track.dill
[ +236 ms] CMake project not found, skipping add_custom_command() VERBATIM migration
[ +48 ms] Building Linux application...
[ +204 ms] <- compile package:menubar/main.dart
[ +32 ms] executing: [build/linux/debug/] cmake -G Ninja -DCMAKE_BUILD_TYPE=Debug /home/rpi4/Desktop/flutter-desktop-embedding/plugins/menubar/linux
[+1009 ms] Wrong full snapshot version, expected '71bf58bdfe725ab5d8df46cf4b929e51' found 'aec2861b8a7fb93059cdbfbaf230c8a4'
[ +434 ms] the Dart compiler exited unexpectedly.  
[ +14 ms] exiting with code 1
0
balaji b r k 20 ene. 2021 a las 10:19

1 respuesta

La mejor respuesta

Flutter actualmente no es compatible con ARM Linux. Puede seguir este problema para obtener actualizaciones.

1
smorgan 20 ene. 2021 a las 10:26