Estoy instalando Flutter y todo está bien, excepto una cosa, especificada anteriormente.

La doctora Flutter dice esto:

$ flutter doctora -v

[√] Flutter (Channel beta, v0.7.3, on Microsoft Windows [Version 10.0.17134.228], locale nl-NL)
    • Flutter version 0.7.3 at C:\Flutter\flutter_windows_new\flutter
    • Framework revision 3b309bda07 (13 days ago), 2018-08-28 12:39:24 -0700
    • Engine revision af42b6dc95
    • Dart version 2.1.0-dev.1.0.flutter-ccb16f7282

[√] Android toolchain - develop for Android devices (Android SDK 27.0.3)
    • Android SDK at C:\Users\iwijsman\AppData\Local\Android\sdk
    • Android NDK location not configured (optional; useful for native profiling support)
    • Platform android-28, build-tools 27.0.3
    • Java binary at: C:\Program Files\Android\Android Studio\jre\bin\java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1024-b02)
    • All Android licenses accepted.

[√] Android Studio (version 3.1)
    • Android Studio at C:\Program Files\Android\Android Studio
    • Flutter plugin version 28.0.1
    • Dart plugin version 173.4700
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1024-b02)

[√] IntelliJ IDEA Community Edition (version 2018.2)
    • IntelliJ at C:\Program Files\JetBrains\IntelliJ IDEA Community Edition 2018.2.2
    • Flutter plugin version 28.0.4
    • Dart plugin version 182.4323.44

[√] Connected devices (1 available)
    • Pixel 2 • FA83P1A01724 • android-arm64 • Android 9 (API 28)

• No issues found!

He agregado la ruta solicitada a las variables y en Androidstudio los complementos están instalados y aplicados, pero sigo recibiendo este error.

Por favor ayúdame, ¿dónde me estoy equivocando?

8
IsaBella Muñoz 10 sep. 2018 a las 17:13

4 respuestas

La mejor respuesta

Como se menciona en el mensaje, es opcional y solo se utiliza para tareas específicas.

Puedes instalarlo desde Android Studio

Menú> Herramientas> Administrador de SDK> SDK de Android (lado izquierdo del cuadro de diálogo)> Herramientas de SDK (pestaña)

Asegúrese de que esta línea esté habilitada

enter image description here

Con [OK] debería instalarse.

16
Günter Zöchbauer 10 sep. 2018 a las 14:19

El mismo problema me enfrentó, pero probar la solución anterior no fue útil. Entonces intenté otra cosa:

  1. Abrir documento
  2. Seleccione la configuración del menú Archivo
  3. Seleccione Idiomas y marcos desde el panel izquierdo
  4. Seleccione Flutter
  5. Luego, desde el panel derecho, elija la ubicación de su SDK de flutter

La ubicación del SDK de flutter es donde copió o clonó el código. En mi caso, fue como lo siguiente: ingrese la descripción de la imagen aquí
Si la ubicación especificada contiene el SDK de flutter, la sección de versión contendrá su versión de flutter. De lo contrario, la sección de versión no contendrá ninguna versión y habrá un mensaje en la parte inferior del cuadro de diálogo de configuración que dice:

Flutter SDK no se encuentra en la ubicación especificada

Espero que esto ayude.

23
AAEM 26 jul. 2019 a las 13:32

Coloque la carpeta Flutter en el escritorio e intente nuevamente configurar la ruta sdk de flutter

Mira esto también ..

https://flutter.dev/docs/get-started/install/windows

0
PRASHANT KARELIYA 26 jul. 2019 a las 13:40

La ruta al SDK debe ser a la carpeta principal de flutter, p. C: \ src \ flutter no a la carpeta bin como se establece en la ruta de variable de entorno.

0
Saqib 11 may. 2020 a las 10:04