Así que estoy publicando esto después de mucha investigación:

Mensaje de advertencia de Android Studio build.gradle Todavía recibo advertencia: la configuración 'compilar' está obsoleta y ha sido reemplazada por 'implementación'

Como muchas de las soluciones sugeridas, actualicé mi versión de google-services a 3.2.0. Aún se acerca la advertencia.

Nótese bien Mi proyecto está usando muchas bibliotecas:

Aquí está proyecto build.gradle :

buildscript {
    repositories {
        google()
        jcenter()
        maven { url 'https://maven.fabric.io/public' }
        maven {
            url 'https://maven.google.com'
        }
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.1.3'
        classpath 'com.jakewharton.hugo:hugo-plugin:1.2.1'
        classpath 'com.getkeepsafe.dexcount:dexcount-gradle-plugin:0.8.3'
        //classpath 'com.neenbedankt.gradle.plugins:android-apt:1.8'
        classpath 'com.google.gms:google-services:3.2.0'
        classpath 'io.fabric.tools:gradle:1.22.1'


        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven { url 'https://jitpack.io' }
        maven { url 'https://maven.fabric.io/public' }
        maven {
            url 'https://maven.google.com'
        }
    }
}

Aquí están todas las bibliotecas en nivel de aplicación build.gradle

Dependencias de la unidad de la unidad de los

    implementation "com.android.support:appcompat-v7:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:cardview-v7:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:design:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:gridlayout-v7:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:support-v4:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:recyclerview-v7:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:support-v13:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:customtabs:$SUPPORT_LIBRARY_VERSION"
    implementation "com.android.support:multidex:$MULTIDEX_VERSION"

    implementation("com.bottlerocketstudios:barcode:$BARCODE_VERSION@aar") {
        transitive = true;
    }
    implementation "com.bottlerocketstudios:javalockboxlib:$JAVALOCKBOXLIB_VERSION"
    implementation "com.bottlerocketstudios:vault:$VAULT_VERSION"

    implementation "com.github.bumptech.glide:glide:$GLIDE_VERSION"
    implementation "com.github.bumptech.glide:okhttp3-integration:$GLIDE_OKHTTP_VERSION@aar"
    implementation "com.squareup.okhttp3:logging-interceptor:$OKHTTP_LOGGER_VERSION"

    implementation "com.facebook.android:facebook-android-sdk:$FACEBOOK_SDK_VERSION"

    implementation "com.google.android.gms:play-services-auth:$PLAY_SERVICES_VERSION"
    implementation "com.google.android.gms:play-services-gcm:$PLAY_SERVICES_VERSION"
    implementation "com.google.android.gms:play-services-maps:$PLAY_SERVICES_VERSION"
    implementation "com.google.android.gms:play-services-location:$PLAY_SERVICES_VERSION"

    implementation "com.jakewharton:butterknife:$BUTTERKNIFE_VERSION"
    implementation "com.jakewharton.rxbinding:rxbinding:$RX_BINDING_VERSION"
    implementation "com.jakewharton.rxbinding:rxbinding-support-v4:$RX_BINDING_VERSION"
    implementation "com.jakewharton.rxbinding:rxbinding-appcompat-v7:$RX_BINDING_VERSION"
    implementation "com.jakewharton.rxbinding:rxbinding-design:$RX_BINDING_VERSION"
    implementation "com.jakewharton.rxbinding:rxbinding-recyclerview-v7:$RX_BINDING_VERSION"
    implementation "com.jakewharton.threetenabp:threetenabp:$THREETENABP_VERSION"
    implementation "com.jakewharton.timber:timber:$TIMBER_VERSION"
    implementation "com.jakewharton:process-phoenix:$PROCESS_PHEONIX_VERSION"

    annotationProcessor "com.squareup.dagger:dagger-compiler:$DAGGER_VERSION"
    implementation "com.squareup.dagger:dagger:$DAGGER_VERSION"
    implementation "com.squareup.retrofit2:retrofit:$RETROFIT_VERSION"
    implementation "com.squareup.retrofit2:adapter-rxjava:$RETROFIT_VERSION"

    implementation "com.f2prateek.rx.preferences:rx-preferences:$RX_PREFERENCES_VERSION"
    implementation "com.trello:rxlifecycle:$RX_LIFECYCLE_VERSION"
    implementation "com.trello:rxlifecycle-components:$RX_LIFECYCLE_VERSION"
    implementation "io.reactivex:rxjava:$RX_JAVA_VERSION"
    implementation "io.reactivex:rxandroid:$RX_ANDROID_VERSION"

    implementation "pl.charmas.android:android-reactive-location:$REACTIVE_LOCATION_VERSION@aar"
    implementation("com.crashlytics.sdk.android:crashlytics:$CRASHLYTICS_VERSION@aar") {
        transitive = true;
    }
    implementation "com.contentful.java:java-sdk:$CONTENTFUL_JAVA_SDK_VERSION"
    implementation "uk.co.chrisjenx:calligraphy:$CALLIGRAPHY_VERSION"
    implementation "com.flurry.android:analytics:$FLURRY_ANALYTICS_VERSION"


    implementation 'org.jsoup:jsoup:1.11.1'

    testImplementation "junit:junit:$JUNIT_VERSION"
}

Estas son algunas versiones importantes de la biblioteca que estoy usando:

OKHTTP_VERSION=3.8.1
RX_PREFERENCES_VERSION=1.0.0
PLAY_SERVICES_VERSION=15.0.1
BARCODE_VERSION=1.0.3
CONTENTFUL_JAVA_SDK_VERSION=7.5.0
BRFONTVIEW_VERSION=1.0.0
JUNIT_VERSION=4.12
BUTTERKNIFE_VERSION=7.0.1
DAGGER_VERSION=1.2.2
RX_ANDROID_VERSION=1.0.1
RX_JAVA_VERSION=1.0.14
JAVALOCKBOXLIB_VERSION=1.0.0
RX_BINDING_VERSION=0.3.0
CALLIGRAPHY_VERSION=2.1.0
SUPPORT_LIBRARY_VERSION=28.0.0-beta01
RX_LIFECYCLE_VERSION=0.2.0
REACTIVE_LOCATION_VERSION=0.8
RETROFIT_VERSION=2.3.0
CRASHLYTICS_VERSION=2.6.2
FACEBOOK_SDK_VERSION=4.23.0 

La advertencia que recibo:

Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html


Configuration 'debugCompile' is obsolete and has been replaced with 'debugImplementation' and 'debugApi'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dependency-configurations.html

Cualquier idea de cuál está causando el problema.

1
kgandroid 10 sep. 2018 a las 09:52

3 respuestas

La mejor respuesta

El problema es con el plugin jakewharton hugo que estaba usando en la aplicación

classpath 'com.jakewharton.hugo:hugo-plugin:1.2.1'

Enlace relevante:

https://github.com/JakeWharton/hugo/issues/156

3
kgandroid 12 sep. 2018 a las 13:54

Simplemente reemplace compilar -> implementación en el módulo de la aplicación, excepto compileSdkVersion en el módulo de la aplicación

0
Mohd Qasim 10 sep. 2018 a las 07:31

Con la tecla de acceso rápido "CTRL + Shift + F" intente buscar la palabra clave "compilar". Si no queda ninguna modificación, vaya al archivo -> Invalidar cachés / reiniciar. Estos mensajes de error desaparecerán.

0
Sana 10 sep. 2018 a las 07:05