Estoy usando WAMP con php v5.5.12.
Intentando instalar el controlador php de datastax (https://github.com/datastax/php-driver ).
1. Tomo el archivo dll compilado de aquí y lo coloco en / ext carpeta
2. Agregue la extensión = php_cassandra.dll a php.ini
3. Reinicio del servidor WAMP

Recibo este error en el registro de errores de wamp php:

[28-Jan-2016 07:32:57 UTC] Advertencia de PHP: Inicio de PHP: No se puede cargar la biblioteca dinámica 'c: /wamp/bin/php/php5.5.12/ext/php_cassandra.dll' - El módulo especificado no pudo ser encontrado.

También instalé el paquete Pear, pero no hay cambios.
¿Alguien aquí tiene experiencia con el nuevo controlador cassandra en Windows?
¿Cual puede ser el problema?

1
lvil 28 ene. 2016 a las 16:00

2 respuestas

La mejor respuesta

Tampoco pude hacer que el .dll encontrado en el sitio php de pecl funcione. Mismo error.

¡Pero el .dll encontrado aquí funciona!

http://downloads.datastax.com/php-driver/windows/cassandra/

1
Klompenrunner 20 nov. 2018 a las 15:06

Deberá utilizar la versión Thread Safe (TS) y, por supuesto, la de PHP5.5. También necesita usar el x86 si su WAMPServer es de 32 bits y el x64 si WAMPServer es la versión de 64 bits

Ese dll debe colocarse en la carpeta \wamp\bin\php\php5.5.12\ext

1
RiggsFolly 28 ene. 2016 a las 13:34