Intenté instalar html2text a través del compositor en mi aplicación laravel. Aquí hay un enlace al repositorio html2text. https://github.com/mtibben/html2text

He intentado composer require mtibben/html2text dando este error:

[InvalidArgumentException]
No se pudo encontrar el paquete mtibben / html2text en ninguna versión para su estabilidad mínima (estable). Compruebe la ortografía del paquete o su estabilidad mínima

También he intentado composer require https://github.com/mtibben/html2text.git dando este error:

[UnexpectedValueException]
No se pudo analizar la restricción de versión //github.com/mtibben/html2text.git: Cadena de versión no válida "//github.com/mtibben /html2text.git"

enter image description here

¿Cómo instalo html2text?

0
Jethro Hazelhurst 14 nov. 2017 a las 17:41

2 respuestas

La mejor respuesta

Es un paquete php, no se puede instalar con composer require

Es posible que desee leer este tutorial

http://laraveldaily.com/how-to-use-external-classes-and-php-files-in-laravel-controller/

2
arun 14 nov. 2017 a las 14:49

¿Ya tiene un archivo composer.json en su directorio? Si no es así, este podría ser el error, porque en este archivo configurará en qué versión del paquete desea instalar en su proyecto.

¡La segunda excepción da una pista sobre la versión que falta!

Si tiene un archivo composer.json, agregue su contenido a su pregunta para que podamos echarle un vistazo.

Aquí puede encontrar más información:

https://getcomposer.org/doc/01-basic-usage.md#composer-json-project-setup

1
Chris P. Bacon 14 nov. 2017 a las 14:50