Me gustaría usar zvelo / ttlru y tener go get este paquete de github con éxito.

Problema:

Se produce el siguiente error cuando intento go run mi programa go, que contiene el import "github.com/zvelo/ttlru":

go_server.go: 8: 2: código en el directorio /home/.../work_go/src/github.com/zvelo/ttlru espera importar "zvelo.io/ttlru"

¿Que esta mal aquí? No veo ninguna importación de zvelo.io/ttlru en ninguna parte.

4
Rudziankoŭ 14 nov. 2017 a las 15:27

2 respuestas

La mejor respuesta

Intente obtener e importar "zvelo.io/ttlru"

5
CallMeLoki 14 nov. 2017 a las 12:33

Como se indica en el README.md y el mensaje de error, importe desde zvelo.io/ttlru y no github .com / zvelo / ttlru.

Asegúrate de usar go get zvelo.io/ttlru

Luego encontrará la fuente del paquete en /home/.../work_go/src/zvelo.io/ttlru/.

2
Peter Gloor 15 nov. 2017 a las 10:12