Continuar intentando que firebase serve vuelva a funcionar. Acabo de hacer esta pregunta (y obtuve una buena respuesta, gracias): npm ERR! Falta la evaluación de pares: firebase-admin@^7.0.0, requerido por firebase-functions@2.3.1

Al hacer npm list firebase-admin ahora veo el resultado esperado -- firebase-admin@7.3.0.

Sin embargo, firebase serve todavía no funciona. Entiendo esto:

!  Your requested "node" version "6" doesn't match your global version "10"
...
!  The Cloud Functions emulator requires the module "firebase-admin" to be installed. This package is in your package.json, but it's not available. You probably need to run "npm install" in your functions directory.
i  functions: Your functions could not be parsed due to an issue with your node_modules (see above)

Entonces firebase serve todavía no ve el módulo firebase-admin. Que esta pasando? ¿Qué tengo que hacer?

9
Leo 10 may. 2019 a las 01:52

3 respuestas

La mejor respuesta

Estaba viendo lo mismo y parece que puedes degradar tu versión de firebase-tools a 6.8. 0

npm install firebase-tools@6.8.0 -g

(He intentado esto y funciona)

6
Nick Ellsworth 9 may. 2019 a las 23:19

Básicamente, significa que debe degradar a Nodo 6 u 8, no actualizar a 10 (ya que la versión del nodo en su sistema es 10 mientras Firebase solicita la versión 6). Firebase aún no es compatible con el Nodo 10+ o incluso la última versión que es 12.15.0

0
Kim Kim 8 feb. 2020 a las 15:22

Parece que este problema ahora se relaciona con la versión de nodo que ha instalado localmente.

No sé la respuesta en la parte superior de mi cabeza, pero empiezo a buscar las versiones de nodo.

En sus funciones / package.json, puede ser que necesite especificar qué versión de nodo usar (https://firebase.google.com/docs/functions/manage-functions):

// functions/package.json

{
  "name": ...,
  "scripts": ...,
  "dependencies": ...,
  
  "engines": {
    "node": "10"
  }
 
}

Solo tenga en cuenta que el Nodo 10 todavía está en beta en Firebase.

5
Dharman 8 feb. 2020 a las 15:53