Estoy intentando instalar el siguiente paquete de redacción:

composer require cr/hashcli

Es un paquete que hice. Pero cuando intento instalarlo, aparece el siguiente error:

[InvalidArgumentException] No se pudo encontrar el paquete cr / hashcli en ninguna versión para su estabilidad mínima (estable). Verifique la ortografía del paquete o su estabilidad mínima

Mi composer.json es el siguiente:

{
"name": "cr/hashcli",
"description": "HashCLI - PHP CLI Tool For hashing",
"type": "library",
"keywords": ["hash", "cli"],
"license": "MIT",
"require": {
    "php": ">=5.5"
},
"require-dev": {
    "phpunit/phpunit": "^5.7"
},
"bin":[
    "src/hashCLI"
],
"autoload": {
    "classmap": [
        "src/"
    ]
},
"autoload-dev": {
    "classmap": [
        "tests/"
    ]
}
}

¿Alguna idea de por qué está sucediendo esto y cómo puedo resolver este problema?

23
Cláudio Ribeiro 14 dic. 2016 a las 21:25

3 respuestas

La mejor respuesta

No existe una versión estable de este paquete. Utilizar

composer require cr/hashcli:dev-master
54
Bizley 14 dic. 2016 a las 18:32

Como mencionaste que eres el autor del paquete, debes crear una versión si crees que tu versión puede usarse en producción.

Puedes hacer esto en GitHub:

  1. Haga clic en 0 releases ingrese la descripción de la imagen aquí

  2. Crea una nueva versión ingrese la descripción de la imagen aquí

  3. Cree una versión de lanzamiento, tal vez v1.0, agregue una descripción y presione el botón: ingrese la descripción de la imagen aquí

Te recomiendo que leas esto para saber cuándo debes nombrar una versión v1.0.1 o v1.1 o v.2.0-alpha etc. Aquí hay un pequeño extracto:

  1. Una vez que se ha lanzado un paquete versionado, el contenido de esa versión NO DEBE modificarse. Cualquier modificación DEBE publicarse como nueva versión.

En otras palabras, si envía algo a su repositorio y no crea otra versión. Las personas solo pueden descargar la última versión a través de Composer.

6.La versión del parche Z (x.y.Z | x> 0) DEBE incrementarse si solo se introducen correcciones de errores compatibles con versiones anteriores. Una corrección de errores se define como un cambio interno que corrige un comportamiento incorrecto.

Para las correcciones de errores que no rompen nada, puede actualizar a v1.0.1

7.La versión menor Y (x.Y.z | x> 0) DEBE incrementarse si se introduce una nueva funcionalidad compatible con versiones anteriores en la API pública. DEBE incrementarse si alguna funcionalidad de API pública está marcada como obsoleta. [...]

Si agrega una nueva funcionalidad que no rompe el código, debe llamar a la próxima versión v1.1.0.

8.La versión principal X (X.y.z | X> 0) DEBE incrementarse si se introducen cambios incompatibles con versiones anteriores en la API pública.

Si hace algo que puede romper el código de otras personas, puede llamar a la nueva versión v2.0

9.Una versión preliminar PUEDE indicarse agregando un guión y una serie de identificadores separados por puntos inmediatamente después de la versión del parche. Los identificadores DEBEN comprender sólo alfanuméricos ASCII y guión [0-9A-Za-z-].

Todo lo que se llame v1.3-alpha o v1.3-christmas se verá como una versión preliminar.

13
Adam 5 sep. 2019 a las 08:08

Para aquellos que usan Packagist, Composer y GIT desde la línea de comandos, simplemente etiqueten su paquete después de enviarlo a GitHub:

git push origin master
git tag v1.0.0
git push --tags

Y siempre que ya haya creado el GitHub Hook para Packagist, Packagist se actualizará en unos minutos y luego puede ejecutar composer require my-user/my-package desde su proyecto de consumo.

1
tonix 23 sep. 2020 a las 16:14