Tengo un jenkins v 2.36 recién instalado en ubuntu 14.04 LTS. durante el proceso de instalación, jenkins instaló todos los complementos excepto la tubería y se atascó en la instalación. Después de eso reinicié jenkins con service jenkins restart y pudo crear un nuevo usuario administrativo. Aquí está la captura de pantalla del error en el tablero de jenkins, el botón correcto no corrige este error. ¿Qué debo hacer para resolver este error?

enter image description here

El error es

There are dependency errors loading some plugins:
Pipeline: Stage View Plugin v2.4
pipeline-rest-api v2.4 is missing. To fix, install v2.4 or later.
Pipeline v2.4
Pipeline: Stage View Plugin v2.4 failed to load. Fix this plugin first.
7
satch_boogie 13 dic. 2016 a las 12:49

2 respuestas

La mejor respuesta

Siempre es bueno instalar el complemento a través de "Manage Jenkins -> Plugin Manager", para que el complemento instale sus dependencias automáticamente.

Pero a veces, debido a una conexión a Internet lenta u otras razones, no funciona automáticamente. En ese caso, debemos hacerlo manualmente bajo Manage Plugins -> Advances Option -> Upload plugin.

Entonces, en su caso, está fallando para los dos complementos dependientes a continuación:

pipeline-rest-api v2.4 is missing. To fix, install v2.4 or later.

Instale el complemento pipeline-rest-api. Además, instale otros complementos dependientes también para un lado más seguro.

Lista de complementos dependientes para cualquier complemento de Jenkins:

9
halfer 16 dic. 2016 a las 21:23

Enlace útil jenkins_dependency_error que me ayudó a resolver este problema

Descargue el complemento desde aquí último canal.

Vaya al panel de jenkins> Administrar jenkins> Administrar complemento> [seleccione la pestaña Avanzado] seleccione cargar el archivo del complemento (seleccione la opción "reiniciar después de la instalación")

3
Community 23 may. 2017 a las 12:02