Estoy intentando instalar Scrapy con easy_install -U Scrapy pero termina en un extraño error "No se puede abrir el archivo de inclusión" al intentar instalarlo. ¿Alguien sabe qué está pasando? Aquí está mi rastreo completo:

C:\Users\Mubashar Kamran>easy_install -U Scrapy
Searching for Scrapy
Reading https://pypi.python.org/simple/Scrapy/
Best match: scrapy 0.24.4
Processing scrapy-0.24.4-py2.7.egg
scrapy 0.24.4 is already the active version in easy-install.pth
Installing scrapy-script.py script to C:\Python27\Scripts
Installing scrapy.exe script to C:\Python27\Scripts
Installing scrapy.exe.manifest script to C:\Python27\Scripts

Using c:\python27\lib\site-packages\scrapy-0.24.4-py2.7.egg
Processing dependencies for Scrapy
Searching for cryptography>=0.2.1
Reading https://pypi.python.org/simple/cryptography/
Best match: cryptography 0.5.4
Downloading https://pypi.python.org/packages/source/c/cryptography/cryptography-
0.5.4.tar.gz#md5=4fd1f10e9f99009a44667fabe7980aec
Processing cryptography-0.5.4.tar.gz
Writing c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cryptography-0.
5.4\setup.cfg
Running cryptography-0.5.4\setup.py -q bdist_egg --dist-dir c:\users\mubash~1\ap
pdata\local\temp\easy_install-jjms3i\cryptography-0.5.4\egg-dist-tmp-ry6bwd
C:\Python27\lib\distutils\dist.py:267: UserWarning: Unknown distribution option:
 'setup_requires'
  warnings.warn(msg)
_Cryptography_cffi_684bb40axf342507b.c
   Creating library c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cry
ptography-0.5.4\cryptography\hazmat\primitives\__pycache__\Release\cryptography\
hazmat\primitives\__pycache__\_Cryptography_cffi_684bb40axf342507b.lib and objec
t c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cryptography-0.5.4\cr
yptography\hazmat\primitives\__pycache__\Release\cryptography\hazmat\primitives\
__pycache__\_Cryptography_cffi_684bb40axf342507b.exp
_Cryptography_cffi_8f86901cxc1767c5a.c
   Creating library c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cry
ptography-0.5.4\cryptography\hazmat\primitives\__pycache__\Release\cryptography\
hazmat\primitives\__pycache__\_Cryptography_cffi_8f86901cxc1767c5a.lib and objec
t c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cryptography-0.5.4\cr
yptography\hazmat\primitives\__pycache__\Release\cryptography\hazmat\primitives\
__pycache__\_Cryptography_cffi_8f86901cxc1767c5a.exp
_Cryptography_cffi_4ed9e37dx4000d087.c
cryptography\hazmat\bindings\__pycache__\_Cryptography_cffi_4ed9e37dx4000d087.c(
194) : fatal error C1083: Cannot open include file: 'openssl/aes.h': No such fil
e or directory
error: c:\users\mubash~1\appdata\local\temp\easy_install-jjms3i\cryptography-0.5
.4\cryptography\hazmat\primitives\__pycache__\_Cryptography_cffi_684bb40axf34250
7b.pyd: Access is denied
12
Mubashir Kamran SW Engineer 29 ago. 2014 a las 16:44

4 respuestas

La mejor respuesta

Para todos los que terminan en los errores al instalar scrapy, deben seguir http://community.spiceworks.com/how_to/38490-setting-up-scrapy-on-windows-7. Este enlace describe la forma más precisa y fácil de instalar scrapy sin encontrar ningún error en Windows 7 y 8.

1
Mubashir Kamran SW Engineer 2 jul. 2015 a las 09:03

En OSX

brew install openssl y luego posiblemente brew link openssl --force si se le informa que no se crearon enlaces.

Instala Scrapy usando el siguiente comando

env CRYPTOGRAPHY_OSX_NO_LINK_FLAGS=1 LDFLAGS="$(brew --prefix openssl)/lib/libssl.a $(brew --prefix openssl)/lib/libcrypto.a" CFLAGS="-I$(brew --prefix openssl)/include" pip install scrapy

Si lo desea, puede sustituir openssl por libressl.

10
Ash 13 oct. 2015 a las 03:26

Es suficiente para instalar openssl

brew install openssl

Y exportar

export LDFLAGS=-L/usr/local/opt/openssl/lib
export CPPFLAGS=-I/usr/local/opt/openssl/include

En ~ / .bash_profile. Intente evitar vincularse con el parámetro --force porque puede generar conflictos con las bibliotecas del sistema.

2
Pavel Goltsev 10 dic. 2015 a las 09:48

Recibí el mismo error al instalar diferentes aplicaciones de Python. Me faltaba el paquete de desarrollo OpenSSL, resuelto por:

sudo apt-get install libssl-dev
29
Jan Zahradník 3 ene. 2015 a las 17:19