El proyecto se creó en Intellij IDEA con Maven.
Esta es mi configuración: ingrese la descripción de la imagen aquí ingrese la descripción de la imagen aquí

¿Por qué obtengo el error java: diamond operator is not supported in -source 1.5 (use -source 7 or higher to enable diamond operator) cuando intento build project?

0
Jake 27 ago. 2020 a las 16:09

2 respuestas

La mejor respuesta

En el archivo del modelo de objetos del proyecto (pom.xml), debe cambiar la versión de origen y destino del compilador a 1.8. Cambiarlo de cualquier otra manera, a través de preferencias o de otro modo, será finalmente restablecido por Maven en la próxima compilación debido a la prioridad. Maven por defecto tiene una versión de compilador de 1.5.

<properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
</properties>
2
Jason 27 ago. 2020 a las 13:16

Tienes que cambiar la estructura del proyecto

Siga el tutorial

-1
saif ali 27 ago. 2020 a las 13:12