Arreglo y solución:

Gracias a @BoyWithSilver, brevemente, esto es lo que hice para solucionar mis problemas:

  1. agregado .less en la sección de extensiones
  2. eliminó los códigos innecesarios en webpack.config.json, por ejemplo eliminado el plugin extract-text-webpack-plugin
  3. rebajar menos de 3.0.1 a 2.7.0 montones de errores corregidos: longitud de undefined en el archivo index.less en antd.

Actualización 3

Aquí está mi package.json

{
  "name": "mobx-reactjsx",
  "version": "1.0.0",
  "description": dfsdfsdfsd",
  "scripts": {
    "start": "webpack-dev-server --config webpack.config.js --progress --inline",
    "lint": "eslint src"
  },
  "keywords": [
    "react",
    "reactjs",
    "boilerplate",
    "mobx",
    "starter-kit",
    "firebase",
    "re-base"
  ],
  "author": "Winston Fan",
  "license": "MIT",
  "homepage": "https://horizontalvision.azurewebsites.net/",
  "devDependencies": {
    "autoprefixer": "^8.0.0",
    "babel-core": "^6.9.1",
    "babel-loader": "^7.1.2",
    "babel-plugin-import": "^1.6.4",
    "babel-plugin-transform-decorators-legacy": "^1.3.4",
    "babel-preset-es2015": "^6.9.0",
    "babel-preset-react": "^6.5.0",
    "babel-preset-stage-1": "^6.5.0",
    "css-loader": "^0.28.9",
    "extract-text-webpack-plugin": "^3.0.2",
    "less": "^3.0.1",
    "less-loader": "^4.0.5",
    "less-vars-to-js": "^1.2.1",
    "postcss-loader": "^2.1.0",
    "style-loader": "^0.20.2",
    "webpack": "^3.5.5",
    "webpack-dev-server": "^2.7.1"
  },
  "dependencies": {
    "antd": "^3.2.1",
    "firebase": "^4.9.1",
    "mobx": "^3.5.1",
    "mobx-react": "^4.4.1",
    "mobx-react-devtools": "^4.2.15",
    "re-base": "^3.2.2",
    "react": "^16.2.0",
    "react-dom": "^16.2.0"
  }
}

Actualización 2:

  1. Después de eliminar la opción de contexto: // contexto: ruta.resolve (__ dirname, 'dist'), en webpage.config.js

  2. adicional

    javascriptEnabled: verdadero en less-loader en webpack.config.json

Recibí estos errores.

ERROR en ./node_modules/antd/lib/button/style/index.less Error de compilación del módulo:

/ * stylelint-deshabilitar declaración-bang-espacio-antes, no-selectores-duplicados * / ^ No se puede leer propiedad 'longitud' de indefinido en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ antd \ lib \ style \ color \ bezierEasing.less (línea 1, columna -1) @ ./node_modules/antd/lib/button/style/index.js 5: 0-23 @ ./src/index.js @ multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js

ERROR en ./node_modules/antd/lib/style/index.less La compilación del módulo falló:

/ * stylelint-deshabilitar declaración-bang-espacio-antes, no-selectores-duplicados * / ^ No se puede leer propiedad 'longitud' de indefinido en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ antd \ lib \ style \ color \ bezierEasing.less (línea 1, columna -1) @ ./node_modules/antd/lib/button/style/index.js 3: 0-33 @ ./src/index.js @ multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js

ERROR en ./node_modules/antd/lib/style/index.less Error de compilación del módulo: ModuleBuildError: Error de compilación del módulo:

/ * stylelint-deshabilitar declaración-bang-espacio-antes, no-selectores-duplicados * / ^ No se puede leer propiedad 'longitud' de indefinido en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ antd \ lib \ style \ color \ bezierEasing.less (línea 1, columna -1) en runLoaders (F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ webpack \ lib \ NormalModule.js: 195: 19) en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 364: 11 en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 230: 18 en context.callback (F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 111: 13) a en process._tickCallback (internal / process / next_tick.js: 169: 7) @ ./node_modules/antd/lib/style/index.less @ ./node_modules/antd/lib/button/style/index.js @ ./src/index.js @ multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js

ERROR en ./node_modules/antd/lib/button/style/index.less Error de compilación del módulo: ModuleBuildError: Error de compilación del módulo:

/ * stylelint-deshabilitar declaración-bang-espacio-antes, no-selectores-duplicados * / ^ No se puede leer propiedad 'longitud' de indefinido en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ antd \ lib \ style \ color \ bezierEasing.less (línea 1, columna -1) en runLoaders (F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ webpack \ lib \ NormalModule.js: 195: 19) en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 364: 11 en F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 230: 18 en context.callback (F: \ temp \ Playground \ mobx-reactjsx \ node_modules \ loader-runner \ lib \ LoaderRunner.js: 111: 13) a en process._tickCallback (internal / process / next_tick.js: 169: 7) @ ./node_modules/antd/lib/button/style/index.less @ ./node_modules/antd/lib/button/style/index.js @ ./src/index.js @ multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js Niño extract-text-webpack-plugin node_modules / extract-text-webpack-plugin / dist node_modules / css-loader / index.js! node_modules / less-loader / dist / cjs.js ?? ref - 1-2! node_modules / antd / lib / style / index.less: [0] ./node_modules/css-loader!./node_modules/less-loader/dist/cjs.js?{"modifyVars":{"@primary-color":"#193D71"},"root":"F : // temp // Zona de juegos // mobx-reactjsx "," javascriptEnabled ": true}! ./ node_modules / antd / lib / style / index.less 302 bytes {0} [construido] [fallido] [1 error]

ERROR in ./node_modules/css-loader!./node_modules/less-loader/dist/cjs.js?{"modifyVars":{"@primary-color":"#193D71"},"root":"F://temp//Playground//mobx-reactjsx","javascriptEnabled":true}!./node_modules/antd/lib/style/index.less
Module build failed:

/* stylelint-disable declaration-bang-space-before,no-duplicate-selectors */
^
Cannot read property 'length' of undefined
      in F:\temp\Playground\mobx-reactjsx\node_modules\antd\lib\style\color\bezierEasing.less

(línea 1, columna -1) Niño extract-text-webpack-plugin node_modules / extract-text-webpack-plugin / dist node_modules / css-loader / index.js! node_modules / less-loader / dist / cjs.js ?? ref - 1-2! node_modules / antd / lib / button / style / index.less: [0] ./node_modules/css-loader!./node_modules/less-loader/dist/cjs.js?{"modifyVars " : {"@ color primario": "# 193D71"}, "root": "F: // temp // Zona de juegos // mobx-reactjsx", "javascriptEnabled": true}! ./ node_modules / antd / lib / button / style / index.less 302 bytes {0} [construido] [fallido] [1 error]

ERROR in ./node_modules/css-loader!./node_modules/less-loader/dist/cjs.js?{"modifyVars":{"@primary-color":"#193D71"},"root":"F://temp//Playground//mobx-reactjsx","javascriptEnabled":true}!./node_modules/antd/lib/button/style/index.less
Module build failed:

/* stylelint-disable declaration-bang-space-before,no-duplicate-selectors */
^
Cannot read property 'length' of undefined
      in F:\temp\Playground\mobx-reactjsx\node_modules\antd\lib\style\color\bezierEasing.less

(línea 1, columna -1) paquete web: No se pudo compilar.


Actualización 1:

Aquí está mi webpack.config.json

var path = require('path');
var webpack = require('webpack');
const fs  = require('fs');

const ExtractTextPlugin = require("extract-text-webpack-plugin");
const lessToJs = require('less-vars-to-js');
const themeVariables = lessToJs(fs.readFileSync(path.join(__dirname, './scripts/ant-theme-vars.less'), 'utf8'));

module.exports = {
  watch: true,
  context: path.resolve(__dirname, './src'),
  devtool: 'source-map',
  entry: [
    './src/index.js'
  ],
  output: {
    path: path.resolve(__dirname, './dist'),
    filename: '[name].bundle.js'
  },
  plugins: [
    new webpack.HotModuleReplacementPlugin(),
    new ExtractTextPlugin('style.css')
  ],
  resolve: {
    extensions: ['.js', '.jsx']
  },
  module: {
    rules: [{
      test: /\.jsx?$/,
      use: ['babel-loader'],
      include: path.join(__dirname, 'src')
    },
      {
        test: /\.less$/,
        use: ExtractTextPlugin.extract([
          {loader: "css-loader"},
          {loader: "less-loader",
            options: {
              modifyVars: themeVariables,
              root: path.resolve(__dirname, './')
            }
          }
        ])
      },
      {
        test: /\.css$/,
        use: ExtractTextPlugin.extract({
          use: "css-loader"
        })
      },]
  }
};

Ahora el mensaje de error se convierte en:

ERROR en multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js Módulo no encontrado: Error: No se puede resolver './src/index.js' en '/ Users / Winston / tmp / Playground / mobx-reactjsx / src' @ multi (paquete web) -dev-server / client? http: // localhost: 8080./src/index.js

(estructura del proyecto) estructura del proyecto

Tengo index.js en projectfolder / src


Estoy tratando de integrar Ant Design con menos soporte y la función Import on Demand que está aquí: https://ant.design/docs/react/use-with- crear-reaccionar-aplicación en la sección Guía avanzada.

En esta sección, usa react-app-rewired pero mi proyecto usa webpack 3 (mi proyecto se basa en esto https://github.com/mobxjs/mobx-react-boilerplate), por lo que no puedo usar el comando recableado en mi caso.

Entonces encontré otro artículo: https: / /medium.com/@GeoffMiller/how-to-customize-ant-design-with-react-webpack-the-missing-guide-c6430f2db10f

Aquí está mi código:

Package.json

"start": "webpack-dev-server --hot --open",

Webpack.config.json

const fs  = require('fs');

const lessToJs = require('less-vars-to-js');
const themeVariables = lessToJs(fs.readFileSync(path.join(__dirname, './scripts/ant-theme-vars.less'), 'utf8'));
....
module:{
.....
rules:[
.....
test: /\.less$/,

use: [

       {loader: "style-loader"},

       {loader: "css-loader"},

       {loader: "less-loader",

options: {

modifyVars: themeVariables

         }

       }

     ]
]
}

Index.js

import {Button} from 'antd';

<Button type="primary">Hi!</Button>

.babelrc

{

"presets": [

"react",

"es2015",

"stage-1"

 ],

"plugins": [

   ["import", {"libraryName": "antd", "style": true} ],

"transform-decorators-legacy"

 ]

}

Aquí están los mensajes de error de la consola: ingrese la descripción de la imagen aquí

1
Franva 16 feb. 2018 a las 20:29

2 respuestas

La mejor respuesta

El error parece provenir de la imposibilidad de resolver .less archivos. Agregar esto a webpack.config.js debería ayudar a resolverlos:

resolve: {
  extensions: ['.js', '.jsx', '.less']
},

Ha especificado el contexto como carpeta src en la estructura. Esto significa que la entrada debe cambiarse a ./index.js o simplemente ./index Si no pretendía tener la clave context, eliminarla también funcionará.

1
Agney 17 feb. 2018 a las 14:08

Configuración del paquete web (webpack.config.js):

const path = require('path');
const webpack = require('webpack');
const ExtractTextPlugin = require("extract-text-webpack-plugin");
const fs  = require('fs');
const lessToJs = require('less-vars-to-js');
const themeVariables = lessToJs(fs.readFileSync(path.join(__dirname, 'ant-theme-vars.less'), 'utf8'));
module.exports = {
  watch: true,
  context: path.resolve(__dirname, './src'),
  entry: {
    app: './index.js',
  },  
  output: {
    path: path.resolve(__dirname, './dist'),
    filename: '[name].bundle.js',
  },
  devtool: 'source-map',
  resolve: {
    alias: {
      moment: 'moment/src/moment'
    },
  },
  module: {
    rules: [
      {
        test: /.jsx?$/,
        loader: 'babel-loader',
        exclude: /node_modules/,
        query: {
          presets: ['env','react','stage-2']
        }
      },
      {
        loader: 'babel-loader',
        exclude: /node_modules/,
        test: /\.js$/,
        options: {
          presets: ['env','react','stage-2'],
          plugins: [
            ['import', { libraryName: "antd", style: true }]
          ]
        },
      },
      {
      test: /\.scss?$/,
        loader: ExtractTextPlugin.extract({
          fallback: 'style-loader',
          loader: 'css-loader!sass-loader'
        })
      },
      {
        test: /\.less$/,
        use: ExtractTextPlugin.extract([
          {loader: "css-loader"},
          {loader: "less-loader",
            options: {
              modifyVars: themeVariables,
              root: path.resolve(__dirname, './')
            }
          }
        ])
      },
      {
        test: /\.(woff|woff2|eot|ttf|otf|svg|png|jpg,pdf)$/,
        loader: "file-loader"
      },
      {
        test: /\.css$/,
        use: ExtractTextPlugin.extract({
          fallback: "style-loader",
          use: "css-loader"
        })
      },
    ]
  },
  plugins: [
    new ExtractTextPlugin('style.css')
  ],
  devServer: {
    port: 9000,
    contentBase: 'dist'
  }
};

Y package.json:

{
  "name": "ant-design-app",
  "version": "1.0.0",
  "description": "Ant design",
  "main": "index.js",
  "scripts": {
    "start": "webpack-dev-server --config webpack.config.js --progress --inline",
    "build": "webpack -p --config webpack.config.js"
   },
   "repository": {
     "type": "git",
     "url": ""
   },
   "author": "Sivadass",
   "license": "MIT",
   "dependencies": {
      "antd": "^3.1.4",
      "moment": "^2.20.1",
      "react": "^16.2.0",
      "react-dom": "^16.2.0",
   },
   "devDependencies": {
      "babel-core": "^6.24.1",
      "babel-loader": "^7.0.0",
      "babel-plugin-add-module-exports": "^0.2.1",
      "babel-plugin-import": "^1.6.3",
      "babel-plugin-transform-decorators-legacy": "^1.3.4",
      "babel-preset-env": "^1.6.0",
      "babel-preset-react": "^6.24.1",
      "babel-preset-stage-2": "^6.24.1",
      "css-loader": "^0.28.9",
      "extract-text-webpack-plugin": "^2.1.2",
      "file-loader": "^0.11.2",
      "less": "^2.7.3",
      "less-loader": "^4.0.5",
      "less-vars-to-js": "^1.2.1",
      "node-sass": "^4.7.2",
      "postcss-loader": "^2.0.10",
      "sass-loader": "^6.0.6",
      "style-loader": "^0.18.2",
      "sugarss": "^1.0.1",
      "webpack": "^3.10.0",
      "webpack-dev-server": "^2.11.1"
    }
 }

Configuración de variables de tema de Ant (ant-theme-vars.less):

  @primary-color: #4099ff;
  @font-size-base: 16px;
  @font-family : "Proxima Nova", Helvetica Neue, Helvetica, Arial, sans-serif;
  @btn-font-size-lg: 15px;
  @btn-padding-lg : 8px 32px;
  @btn-padding-sm : 4px 16px;
0
Sivadass N 16 feb. 2018 a las 18:09